Полезное

Мы Вконтакте

#
Аватара пользователя
Пользователь
Сообщения: 4
Мой мультиплеерный проект (через steam subsystem)перестал находить сессии. В блюпринтах find sessions выводит в результаты ноль. Проблема появилась после установки злосчастного перфорса. Я удалил его с обоих машин, но проблема осталась. Проект был специально скопирован для перфорса, чтобы не случилось чего, так что он остался в том же виде, в котором был до перфорса. Может быть кто-то сталкивался с подобным или есть какие-то идеи как это исправить?
Аватара пользователя
Пользователь
Сообщения: 1082
Плагин стима в движке включен?
_________________
http://flydreamdev.com/
http://forum.devforfun.ru/
Аватара пользователя
Пользователь
Сообщения: 4
Изначально я просто добавил в DefaultEngine.ini код из документации и всё коннектилось прекрасно.
Код:
[/Script/Engine.GameEngine]
+NetDriverDefinitions=DefName="GameNetDriver",DriverClassName="OnlineSubsystemSteam.SteamNetDriver",DriverClassNameFallback="OnlineSubsystemUtils.IpNetDriver")

[OnlineSubsystem]
DefaultPlatformService=Steam

[OnlineSubsystemSteam]
bEnabled=true
SteamDevAppId=480

[/Script/OnlineSubsystemSteam.SteamNetDriver]
NetConnectionClassName="OnlineSubsystemSteam.SteamNetConnection"


После перфорса работать перестало. Пробовал Steam Setup Utility, эффекта - ноль.
Аватара пользователя
Пользователь
Сообщения: 4
Нашел плагин, спасибо за ответ! Появился оверлей, которого я не мог раньше добиться, но сессии все ещё не находятся.
Аватара пользователя
Пользователь
Сообщения: 4
Ап: Max results на Find Sessions должен быть больше (у меня заработало на 1000).

Странно то, что до Perforce'а все работало и на пяти...


Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 5

UEngine.ru © 2017
Все права защищены. При копировании материалов с сайта, ссылка на первоисточник обязательна.
Яндекс.Метрика
Главная страница