Полезное

Мы Вконтакте

Импорт Skeletal Mesh

Добавлено Мар 19 2016

Skeletal Mesh поддерживает импорт FBX файлов, что обеспечивает удобный рабочий процесс, для получения анимированных объктов из 3D приложений в Unreal Engine 4, для использования в играх.Помимо самого объекта, в импортируемом FBX файле может содержаться также анимации, морфы, а назначенные в 3D редакторе текстуры (диффуз и нормал) будут автоматически использованы в материале при импорте файла в UE4..

Особенности поддерживаемые скелетными объектами, используя FBX:

  1. Материалы содержащие текстуры
  2. Анимации
  3. Morph Targets
  4. Несколько UV развёрток
  5. Группы сглаживания
  6. Vertex colors
  7. Лодирование
На данный момент, для каждого скелетал меша, возможно использовать в одном файле только одну анимацию. В тоже время, в одном файле можно использовать несколько морфов для скелетал меша.
В UE4 используется версия FBX 2014.Использование других версий при экспорте, может вызвать некоторые отклонения.
Данная страница содержит в себе информация как для Autodesk Maya так и для Autodesk 3ds Max.Будьте внимательны при выборе показываемого варианта:

Цельный и многообъектый меш

Skeletal Meshes могут состоять как из одного меша, так и сотавленные из нескольких объектов, и заскиненных на один скелет.

Скелетал меши в unreal engine 4

Использование нескольких мешей даёт возможность по разному ЛОДировать каждый объект, а также при использовании модульной системы создания персонажа.Такой метод не даёт потери производительности. Все индивидуальные части будут объедененны в один меш, после того, как они будут импортированы в редактор движка.

Rigging

Rigging — означает привязку меша к скелетной иерархии костей/джоинтов. Это даёт костям/джоинтам влиять на вертексы меша при последующей деформации при движении.

Для Maya существуют инструменты, которые включают в себя заригенненого персонажа и анимационные решения. Maya Animation & Rigging Tools находятся в папке с UE4 \Engine\Extras\Maya_AnimationRiggingTools\MayaTools.

Скелет

Maya

В Maya, вы можете использовать Joint Tool для создания скелета вашего скелетал меша. Опять же, существует огромное количество различных уроков по использованию этого инструментария для создания рига в Maya.
Скелетал меши в unreal engine 4

Плотность скелета сильно возрасла по сравнению с Unreal 3

3Ds Max

То, как вы создадите скелетную анимацию в 3dsmax — дело ваше. Вы можете использовать стандартный инструмент Bones Tools, или любой друго удобный вам метод для ригинга вашего персонажа.
Скелетал меши в unreal engine 4

Привязка

Maya

В Maya, меш(и) привязаны к скелету посредством Smooth Bind команды.Процесс этот одинаков, что для скелетал меша состоящего из цельного объекта, что состоящего из нескольких объектов.

  1. Выберите меш(и) который хотите привязать.
    Скелетал меши в unreal engine 4
  2. Shift + выбор корневого (root) джоинта скелета.
    Скелетал меши в unreal engine 4
  3. Выберите Smooth Bind из Skin > Bind Skin меню.
    Скелетал меши в unreal engine 4
  4. Теперь вы можете настроить веса вершин меша для каждого джоинта, для определения того, какие кости будут влиять на те или другие вершины и с каким углом.Вы можете это сделать используя Paint Skin Weights Tool, ну или любой другой способ который вам удобен.
    Скелетал меши в unreal engine 4

3Ds Max

В 3dsMax, меш(и) должны быть привязаны к скелету посредством модификатора Skin. Процес аналогичен как для целого объекта, так и для состоящего из нескольких частей.

  1. Выберите меш(и) которые хотите привязать.
    Скелетал меши в unreal engine 4
  2. Добавьте модификатор Skin из списка модифкаторов.
    Скелетал меши в unreal engine 4
  3. В разворачивающемся модификаторе Skin, кликните по кнопке skin_add_button.jpg для добавления костей которые влияют на меш. Откроется окошко Select Bones.
    Скелетал меши в unreal engine 4
  4. Выберите кости в окне Select Bones и кликните по кнопке Select для добавления костей.
    Скелетал меши в unreal engine 4
  5. Теперь кости отображаются в списке модификатора Bones.
    Скелетал меши в unreal engine 4
  6. Теперь вы можете настроить веса вершин меша для каждой кости для указания какая вершина окажется под влиянием какой кости и под каким углом.Это может быть сделано посредством использования envelopes, напряму указывая веса вершин, ну или другим удобным для вас способом.
    Скелетал меши в unreal engine 4

Пивот

Пивот меша в Unreal Engine обозначает точку, вокруг которой будет происходить трансформация объекта (перемещение,поворот,масштабирование).

Скелетал меши в unreal engine 4

Пивот скелетал меша всегда расположен в корневой кости/джоинте скелета.Это означает, что независимо от того, где расположен рут скелета в сцене, при экспорте из 3d приложения, он всегда будет иметь нулевые координаты (0.0.0).

Скелетал меши в unreal engine 4

Триангуляция

Меши в Unreal Engine должны быть триангулированы, ибо графическое оборудование работает только с триугольниками.
Скелетал меши в unreal engine 4

Несколько методов триангуляции вашего меша.

  1. Меш состоит только из триугольников — лучшее решение, дающее наибольше контроля над конечным результатом.
  2. Триангулировать меш в 3d приложении — хорошее решение, дающее чистку и модификацию перед экспортом.
  3. Дать импортёру триангулировать меш — нормальное решение, не дающее чистки, но может работать на простых мешах.
  4. Дать FBX экспортёру триангулировать меш — нормальное решение, не дающее чистки, но может работать на простых мешах.
Когда выбрано Split Non-Matching Triangles, FBX экспортёр триангулирует меш случайно сглаживая поверхность в подобных непонятных ситуациях. Импортирование FBX-триангулированного меша обратно в Maya и ре-экспорт покажет правильное сглаживание.

Наилучшее решение — вручную триангулировать меш в 3d приложении, контролируя направления и расположения эджей. Автоматическая триангуляция может привести к нежелательным результатам.

Скелетал меши в unreal engine 4

Создание карт нормалей

Карты нормалей могут быть созданы для вашего меша, непосредственного в том 3d приложении, в котором вы работаетe.

Скелетал меши в unreal engine 4

Геометрия высоко детализированных мешей используется для генерации с них нормалей для карты нормалей. Epic используют в своём пайплайне XNormal, который даёт наилучшие нормали, для их последующего рендеринга в Unreal Engine 4. Больше от этом процессе — Гайд по созданию Normal Map.

Материалы

Материалы применяемые к моделям экспортируются вместе с самой моделью из внешнего приложения и потом импортируются в unreal.Это позволяет не создавать вручную материалы и не добавлять текстуры отдельно.Все эти действия поддерживаются при FBX пайплайне.

Эти метериалы также необходимо настраивать, в случае, если на объект наложены несколько материалов, к примеру, если материал тела имеет id0, а головы id1.

Для получения подробных сведений о настройке материалов для экспорта,смотри FBX Material Pipeline .

Цвета Вершин

Цвета вершин (один комплект только) для скелетал мешей могут быть переданы через FBX пайплайн. Не требуется дополнительная настройка.

Скелетал меши в unreal engine 4

Экспорт мешей из 3D приложения

Skeletal Meshes могут быть экспортированы индивидуально или сразу несколько в один FBX файл. Пайплайн импорта разделит несколько скелетал мешей на несколько ассетов в целевом паке.

Maya

  1. Выберите во вьюпорте меш(и) и джоинты для экспорта.
    Скелетал меши в unreal engine 4
  2. В меню File выберите Export Selection (или Export All если хотите экспортировать все объекты находящиеся в сцене).
    Скелетал меши в unreal engine 4
  3. Выберите место и имя FBX файла для экспорта меша(ей) и установить необходимые параметры в диалоге FBX-экспорта, после чего нажмите кнопкуmaya_export_button.jpg
    Скелетал меши в unreal engine 4

3Ds Max

  1. Выберите во вьюпорте меш(и) и кости для экспорта.
    Скелетал меши в unreal engine 4
  2. В меню File, выберите Export Selected (или Export All если хотите экспортировать все объекты находящиеся в сцене).
    Скелетал меши в unreal engine 4
  3. Выберите место и имя FBX файла для экспорта меша(ей), после чего нажмите кнопку Скелетал меши в unreal engine 4.
    Скелетал меши в unreal engine 4
  4. Установить необходимые параметры в диалоге FBX-экспорта и нажмите кнопку Скелетал меши в unreal engine 4 для создания FBX файла содержащего меш(и).
    Скелетал меши в unreal engine 4

Импорт Мешей

  1. Клините по кнопке Скелетал меши в unreal engine 4 в Content Browser.
  2. Найдите и выберите тот файл, который вы хотите импортировать.

    Вы можете выбрать Скелетал меши в unreal engine 4 в Content Browser в выпадающем меню можете выбрать только тот формат файлов, который вы хотите видеть.

    Скелетал меши в unreal engine 4

    Путь импортируемого ассета зависит от текущего расположения в контент браузере в момент импорта.Убедитесь что вы находитесь в нужной папке.Тем не менее вы можете переместить импортированный файл после импорта в нужную папку.
  3. Выберите необходимые настройки в диалоговом окне FBX Import Options. Значения по умолчанию должно быть достаточно при импорте меша, который не разделяется с существующий скелет.
    Скелетал меши в unreal engine 4
  4. Если Skeletal Mesh импортировался и отделился от существующего скелета, то кликните по Select Skeleton в выпадающем меню и выберите нужный скелет из списка.
    Скелетал меши в unreal engine 4
  5. Кликните по кнопке Скелетал меши в unreal engine 4 для импорта меша(ей).

Итоговый меш (если отмечены пукты импорта материалов и текстур) будет показан в контент браузере, в случае успешного импорта.
Скелетал меши в unreal engine 4

При импорте вы можете просто перетащить ваш файл из файлового браузера вашей ОС в окно Content браузера UE4.

При просмотре импортированного меша вы можете убедится, что всё получилось как и ожидалось.

Скелетал меши в unreal engine 4

LOD’ы скелетал мешей

Скелетал меши могут использовать ЛОДы в игре, для того, чтобы уменьшить нагрузку от сетки меша при отдалении камеры от него.Как правильно, это узначает, что каждый уровень ЛОДа будет уменьшать количество триугольников, упрощать скелет, и возможно упрощать материал применённый к нему.

FBX пайплайн позволяет использовать импорт/экспорт этих ЛОДов.

Настройки ЛОДов

В основном, ЛОДы создаются путём уменьшения полигонажа исходного меша. Все они (ЛОДы) должны быть выровнены и совмещены в одном и том же пивоте; а также заскиненны на один скелет. Для скелетал мешей возможно, что они будут состоять из нескольих частей в 3d редакторе. Каждая из этих частей может иметь ЛОДы независимо от остального меша. Это значит, что некоторые части могут иметь более простую сетку по сравнению с другими частями, которые будут использовать более детализированную сетку. Какждый ЛОД может иметь свой индивидуальный материал. Это значит, что вблизи к объекту материал будет более детализирован, а с отдалением будет заменятся на более простой материал.

Maya

Выберите все меши (основной + лоды) в порядке уменьшения полигонажа, т.е. сначала выбераете базовый меш, потом первый ЛОД, потом второй ЛОД, и так далее.Это важно для сохранения очерёдности и сохранения структуры ЛОДов. Затем, выберите команду Level of Detail > Group из меню Edit.
Скелетал меши в unreal engine 4

Теперь у вас есть группа мешей сгрупированных в ЛОД группу.

Скелетал меши в unreal engine 4

3Ds Max

  1. Выберите все меши (базовый + ЛОДы, порядок не важен), потом выберите команду Group из Group меню.
    Скелетал меши в unreal engine 4
  2. Впишите имя новой группы в открывшемся диалоговом окне и кликните по кнопке Скелетал меши в unreal engine 4 для создания группы.
    Скелетал меши в unreal engine 4
  3. Кликните по кнопке Скелетал меши в unreal engine 4 для просмотра панели Utilities и выберите утилиту Level of Detail.
    Вам нужно будет кликнуть по Скелетал меши в unreal engine 4 и выбрать из списка.
    Скелетал меши в unreal engine 4
  4. Когда группа выделена, кликните по кнопке Скелетал меши в unreal engine 4 для создания нового ЛОД сета добавьте меши выбранной группы.Меши будут автоматически упорядочены исходя из их полигонажа.

    Скелетал меши в unreal engine 4

Многосоставные ЛОДы

Настройка ЛОДов для многосоставных скелетал мешей почти идентична настройке ЛОДов обычного меша, с той лишь разницей, что каждая индивидуальная часть которая имеет ЛОДы, должна иметь ЛОД группу.Процесс создания этих индивидуальных групп идентичен тому, что описан выше.

Экспорт LOD’ов

Maya

  1. Выберите ЛОД групу(пы) и джоинты, которые вы хотите экспортировать.
    LOD группы в maya
  2. Следуйте тем же этапам экспорта, что и при экспорте базового меша (описано выше в разделе экспорт меша)

3Ds Max

  1. Выберите ЛОД групу(пы) и костей, которые вы хотите экспортировать.
    LOD группы в 3ds max
  2. Следуйте тем же этапам экспорта, что и при экспорте базового меша (описано выше в разделе экспорт меша)

Импорт LOD’ов

ЛОДы скелеталМеша могут быть легко импортированны через панель Mesh Details в Persona под настройками ЛОДов.

  1. Откройте СкелеталМеш к которому вы хотите применить ЛОДы, и перейдите в Mesh Tab.
  2. На панели Mesh Details пролистайте вниз и найдите пункт LOD Settings, и нажмите LOD Import.
    FBX Skeletal Mesh Pipeline
  3. Найдите и выберите требуемый FBX файл.
    FBX Skeletal Mesh Pipeline
  4. Импортированный лод будет добавлен на Mesh Details панель
    FBX Skeletal Mesh Pipeline
  5. Под каждым ЛОДом,параметр Screen Size показывает, когда будет применяться ЛОД.
    FBX Skeletal Mesh Pipeline

    Использование маленьких значений, подразумевает, что ЛОД будет включать на далёком расстоянии, а при больших значениях на близком.На изображении выше показано, что ЛОД0 используется при плизких рассотяниях до СкелеталМеша, а ЛОД1 на дальних расстояниях.
  6. Когда импортируете или добавляете ЛОДы, Reduction Settings также могут быть настроены для ЛОДов.
    FBX Skeletal Mesh Pipeline

Экспорт в FBX из Unreal Editor

СкелеталМеши ранее импортированные в UE4, могут быть экспортированы обратно в FBX файл из контент браузера.

Ассеты в запакованных паках не могут быть экпортированны как исходные данные.
  1. В контент браузере выберите СкелеталМеш который вы хотите экспортировать.
    FBX Skeletal Mesh Pipeline
  2. Правым кликом мышки по СкелеталМешу выберите Asset Actions > Export.
    FBX Skeletal Mesh Pipeline
  3. Выберите место имя файла который вы экспортируете.Удостовертесь, выбран ли (*.FBX) формат файла.
    FBX Skeletal Mesh Pipeline
Добавил: RedComrade Категория: Работа с контентом


Комментарии

На данный момент комментарии отключены.

UEngine.ru © 2017
Все права защищены. При копировании материалов с сайта, ссылка на первоисточник обязательна.
Яндекс.Метрика
Главная страница